DL_POLY v4.08

DL_POLY is a general purpose serial and parallel molecular dynamics simulation package developed at Daresbury Laboratory by W. Smith, T.R. Forester and I.T. Todorov. The original package was developed by the Molecular Simulation Group (now part of the Computational Chemistry Group, MSG) at Daresbury Laboratory under the auspices of the Engineering and Physical Sciences Research Council (EPSRC) for the EPSRC's Collaborative Computational Project for the Computer Simulation of Condensed Phases (CCP5). Later developments were also supported by the Natural Environment Research Council through the eMinerals project. The package is the property of the Central Laboratory of the Research Councils.

Two versions of DL_POLY are currently available. DL_POLY_Classic is the original version which has been parallelised using the Replicated Data strategy and is useful for simulations of up to 30,000 atoms on 100 processors. DL_POLY_4 is a version which uses Domain Decomposition to achieve parallelism and is suitable for simulations of order 1 million atoms on 8-1024 processors.

Note that CUDA (GPU) support for DL_Poly was discontinued at version 4.05; there is no CUDA implementation of this version.

This help page describes the use of DL_POLY 4; DL_POLY Classic is also available and has a separate help page.

Accessing the software

To load the module:

$ module load apps/dlpoly4/v4.08

An example command to include in your job script:

mpiexec DLPOLY.Z

Note:

  • DL_POLY has been built to run in parallel so it must be called with mpiexec.
  • You must be in a directory which contains the input files CONFIG, CONTROL, and FIELD before running mpiexec DLPOLY.Z.

Accessing Previous Versions

Wherever possible, previous versions of this application will be retained for continuity, especially for research projects that require a consistent version of the software throughout the project. Such versions, however, may be unsupported by IT Services or the applications vendor, and may be withdrawn at short or no notice if they can no longer run on the cluster - for example, essential operating system upgrades may be incompatible with old versions.

Previous versions of this application are recorded below:

Known Problems & Limitations

None.

Other Information

The Support Level for this application is P2.

Visit the DL_POLY website for more information regarding this application.


Last modified: 5 October 2017